?>
ОЧЕНЬ Даны две дроби a/b и c/d (a, b, c, d – натуральные числаответ должен быть несократимой дробью x/y.Составить программу умножения дроби на дробь. При выполнении задания использовать подпрограмму-функцию для вычисления произведений двух пар целых чисел: ac, bd и их распечатки. Числитель произвед х= Знаменатель произвед у= ПАСКАЛЬ, и составить блок-схему
Ответы
// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018
// Внимание! Если программа не работает, обновите версию!
type
TRAIN = record
ПунктНазначения: string;
НомерПоезда: string;
ВремяОтправления: DateTime
end;
procedure ВводДанных(Список: List<TRAIN>);
begin
var Поезд: TRAIN;
var ЧЧММ: string;
for var i := 1 to 6 do // 6 поездов
begin
Println('Ввод данных о поезде', i);
Поезд.ПунктНазначения := ReadlnString('Пункт назначения:');
Поезд.НомерПоезда := ReadlnString('Номер поезда:');
repeat
ЧЧММ := ReadlnString('Время отправления (ЧЧ:ММ):');
until DateTime.TryParse(ЧЧММ, Поезд.ВремяОтправления);
Список.Add(Поезд)
end
end;
procedure ПоискПоездов(Список: List<TRAIN>; ПунктНазначения: string);
begin
var Отобрано:=
Список.Where(Поезд->Поезд.ПунктНазначения=ПунктНазначения);
if Отобрано.Count>0 then
foreach var Поезд in Отобрано do
Writeln($'{Поезд.НомерПоезда} {Поезд.ВремяОтправления:HH-mm}')
else
Println('Нет поездов на это направление')
end;
begin
var Поезда := new List<TRAIN>;
ВводДанных(Поезда);
ПоискПоездов(Поезда,ReadlnString('Куда едем?'))
end.