shumilovs7252
?>

Приветствую Вас всех Нужны программисты, которые пишут на С#Надо выполнить 6 любых заданийЗадание №1. Написать программу, которая реализует диалог с пользователем: запрашивает с клавиатуры три целых числа, и выводит на экран произведение данных чисел в прямом и обратном порядке: Задание №2. Написать программу: . Дано трехзначное число. Найти произведение его цифр. Задание №3. Написать программу, которая подсчитывает: . периметр прямоугольного треугольника по двум катетам a, b. Задание №4. Написать программу: Определить время падения камня на поверхность земли с высоты h. Задание №5. Написать программу: . Вычислите дробную часть среднего арифметического и дробную часть среднего геометрического трех заданных чисел. Задание №6. Вычислить значение функции для заданного значения аргумента y=20lncos e^x- 2/√(〖sin〗^(3+|1-x^2 |) ) x=0, 7 Задание №7. Написать программу, вычисляющую: . a^15 за пять операции, а – действительное число, при этом, не пользуясь никакими другими арифметическими операциями, кроме умножения Задание №8. В трехзначном числе х зачеркнули его вторую цифру. Когда к образованному при этом двузначному числу справа приписали вторую цифру числа х, то получилось число n. По заданному n найти число х (значение n вводится с клавиатуры, 100 ≤ n ≤ 999 ​

Информатика

Ответы

sanina611

Program ToDec;

Uses crt;
var s:string;
n,l,i:integer;

 

function Pow(x,y:integer):integer;
begin
     if y>0 then Pow:=Pow(x,y-1)*x
               else Pow:=1;
end;

function ToDec(A : string) : integer;
var L : Byte;
begin
      if A = '' then ToDec := 0
                else begin
                              L := length(A);
                               case A[1] of
                                     '0' : ToDec := ToDec(Copy(A, 2, L - 1));
                                     '1' : ToDec := Pow(2, L - 1) + ToDec(Copy(A, 2, L - 1));
                                end;
     end;
end;

begin
     clrscr;
     write('Введите двоичное число: ');
     readln(s);
      writeln('Это число в десятичной системе : ', ToDec(S));
 readkey;
end.

 

 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Приветствую Вас всех Нужны программисты, которые пишут на С#Надо выполнить 6 любых заданийЗадание №1. Написать программу, которая реализует диалог с пользователем: запрашивает с клавиатуры три целых числа, и выводит на экран произведение данных чисел в прямом и обратном порядке: Задание №2. Написать программу: . Дано трехзначное число. Найти произведение его цифр. Задание №3. Написать программу, которая подсчитывает: . периметр прямоугольного треугольника по двум катетам a, b. Задание №4. Написать программу: Определить время падения камня на поверхность земли с высоты h. Задание №5. Написать программу: . Вычислите дробную часть среднего арифметического и дробную часть среднего геометрического трех заданных чисел. Задание №6. Вычислить значение функции для заданного значения аргумента y=20lncos e^x- 2/√(〖sin〗^(3+|1-x^2 |) ) x=0, 7 Задание №7. Написать программу, вычисляющую: . a^15 за пять операции, а – действительное число, при этом, не пользуясь никакими другими арифметическими операциями, кроме умножения Задание №8. В трехзначном числе х зачеркнули его вторую цифру. Когда к образованному при этом двузначному числу справа приписали вторую цифру числа х, то получилось число n. По заданному n найти число х (значение n вводится с клавиатуры, 100 ≤ n ≤ 999 ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Роман
gullieta
Astrians
armynis8
dianakryukova00
anytkaakk
pannotolstova488
joini09
Филипп1054
irinalav2705745
stic1995
Bezzubova_Stepanov1355
Kati2005
Nadezhda
КараханянКусков
▲