emilmishin1032
?>

Составить программу, которая выводит n двузначных натуральных чисел (n вводит пользователь), которые делятся на 4. Посчитать сумму и количество этих чисел.

Информатика

Ответы

Golubovskayairina

#include <stdio.h>

int main()

{

int N;

int temp;

int sum;

printf("Input a number: ");

scanf("%d", &N);

while (N % 4)

{

printf("a number is not divisible by 4!\n");

printf("Enter the number again:\n");

scanf("%d", &N);

}

printf("Input %d numbers from 10 to 99: \n", N);

for (int i = 0; i < N; i++)

{

scanf("d", &temp);

if (temp < 10 || temp > 99) return 0;

sum += temp;

}

printf("sum of numbers: %d\n", sum);

printf("number of numbers: %d\n", N);

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая выводит n двузначных натуральных чисел (n вводит пользователь), которые делятся на 4. Посчитать сумму и количество этих чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gbelihina
prik-galina7390
Paradismebel
moisalexx7
olg53362928
MelnikovaIvanovna
polyakovaelena
Anatolevich_Kulikov1229
РоманТрофимов2012
Федоровна-Васильева
zazaza74
polina3mag
Артур
kol-nat26
Калмыкова-Петрунина