yuraotradnov
?>

В питоне! Ввести с клавиатуры натуральное число и найти сумму значений его цифр. Пример: Введите число: 1234 Cумма цифр 10 Составьте программу для питона

Информатика

Ответы

ivanandrieiev1984268

number = int(input("Введите число: "))

amount = 0

while number > 0:

   amount += number % 10

   number //= 10

print("Сумма цифр =", amount)

Объяснение:

number = int(input("Введите число: ")) # Ввод целочисленного значения с клавиатуры

amount = 0 # Переменная, хранящая сумму, равна 0

while number > 0: # Пока значение переменной number > 0

   amount += number % 10 # // Суммируем последнюю цифру от числа

   number //= 10 # // Отделяем эту цифру

print("Сумма цифр =", amount) # // Выводим ответ

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

В питоне! Ввести с клавиатуры натуральное число и найти сумму значений его цифр. Пример: Введите число: 1234 Cумма цифр 10 Составьте программу для питона
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

grenysherg2873
minchevaelena23
karkh267
ea-office
Титова674
verachus
vbnm100584
turovvlad
yocrew13
petrowanastya202081
smirnovaL1286
Romanovich1658
Lvova_Aleksandr933
million2003
nikiforovako76