Abdulganieva1367
?>

C++ Напишите программу на c++, которая заполняет квадратную матрицу 4х4 случайными числами в интервале [10, 99], и находит максимальный и минимальный элементы в матрице и их индексы

Информатика

Ответы

annapiskun1
Честно, не поняла ваш код вообще. Почему нет цикла? Предлагаю свое решение:
1)Cначала заполняем массив случайными числами от 2 до 5 (включительно)
2)Потом выводим его (Для проверки)
3) Потом считаем оценки. Но сначала нужно обнулить переменные( В самом начале это делали), а то получится кака (:

program N_0547847;
var
    b, c, d, f, i:integer;
    a: array [1..20] of integer;
begin;
randomize;
b:=0; c:=0; d:=0; f:=0;
for i:=1 to 20 do begin
  a[i]:=random(4)+2; 
  write(a[i],' '); end; 
writeln;
for i:=1 to 20 do begin
    if a[i]=2 then  b:=b+1;
    if a[i]=3 then  c:=c+1;
    if a[i]=4 then  d:=d+1;
    if a[i]=5 then   f:=f+1;
end;
writeln('Двоек: ', b); 
writeln('Троек: ', c); 
writeln('Четверок: ',d);
writeln('Пятерок: ',f);
end.   

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

C++ Напишите программу на c++, которая заполняет квадратную матрицу 4х4 случайными числами в интервале [10, 99], и находит максимальный и минимальный элементы в матрице и их индексы
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ag-modul
delta88
Tselyaritskaya Yurevich
Шаленко
kassel1b
Есартия52
cashuta
Viktorovna
marketing
vera-spicina
MArat
mikchaylovaalex
Coffee3862
Федор_Рауф1592
Fedorova_79166180822
▲