pavlino-mkr
?>

Одномерные массивы задача програмирования с++ 3. Имеются десять гирь весом a1, a2, ..., a10. Обозначим через ck — число которыми можно составить вес k, то есть ck — это число решений уравнения a1x1 + a2x2 +...+ a10x10 = k, где xi может принимать значения 0 или 1 (i=1, ..., 10 Получить с0, с1, ..., с10.

Информатика

Ответы

anton1969026203
1.
var
a:array[1..5,1..5] of integer;
i,j,sum,min,n:Integer;
begin
min:=25;
for i:=1 to 5 do
begin
Writeln('Введите места ', i,' спортсмена');
for j:=1 to 5 do
Read(a[i,j]);
end;

for i:=1 to 5 do
begin
for j:=1 to 5 do
sum:=sum+a[i,j];
if sum<min then
begin
min:=sum;
n:=i;
sum:=0;
end;
end;
Writeln(n, ' спортсмен лучший');
end.

2.
var
a:array[1..20,1..20] of integer;
sum:array[1..20] of integer;
i,j,n,k:integer;
begin
Writeln('Введите количество команд');
Readln(n);
For i:=1 to n do
for j:=1 to n do
if i = j then a[i,j]:=0 else
begin
Writeln('Введите количество очков, заработаных ', i ,' командой в матче поротив ', j, ' команды');
Read(a[i,j]);
end;
For i:=1 to n do
for j:=1 to n do
sum[i]:= sum[i]+ a[i,j];

for i:=1 to n do
if sum[i]>(3*(n-1)/2) then k:=k+1;

Writeln(k ,' команд(а,ы) имеют больше побед, чем поражений');
end.

3.
var
a:array[1..20,1..20] of integer;
sum:array[1..20] of integer;
i,j,n:integer;
begin
Writeln('Введите количество команд');
Readln(n);
For i:=1 to n do
for j:=1 to n do
if i = j then a[i,j]:=0 else
begin
Writeln('Введите количество очков, заработаных ', i ,' командой в матче поротив ', j, ' команды');
Read(a[i,j]);
end;
For i:=1 to n do
for j:=1 to n do
sum[i]:= sum[i]+ a[i,j];

for i:=1 to n do
if sum[i] = 3*(n-1) then Write(i, ' ');
Write(' команд(а,ы чемпионат без поражений!');
end.

4.
var
a:array[1..20,1..20] of integer;
sum:array[1..20] of integer;
i,j,n,k:integer;
begin
Writeln('Введите количество команд');
Readln(n);
For i:=1 to n do
for j:=1 to n do
if i = j then a[i,j]:=0 else
begin
Writeln('Введите количество очков, заработаных ', i ,' командой в матче поротив ', j, ' команды');
Read(a[i,j]);
end;
For i:=1 to n do
for j:=1 to n do
if a[i,j]<>1 then
sum[i]:= sum[i]+ a[i,j];

for i:=1 to n do
if sum[i] > (3*(n-1))/2 then k:=k+1;
Write(k,' команд выиграли более половину игр');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Одномерные массивы задача програмирования с++ 3. Имеются десять гирь весом a1, a2, ..., a10. Обозначим через ck — число которыми можно составить вес k, то есть ck — это число решений уравнения a1x1 + a2x2 +...+ a10x10 = k, где xi может принимать значения 0 или 1 (i=1, ..., 10 Получить с0, с1, ..., с10.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

orinvarostov
pelagia-kola2658
Daniil1945
fucksyara
sindika
Wlad967857
Тресков946
Dmitrii sergei463
knyazevskayad
alf206
Aivazyan
sharkova1443
Irina_Nikolai
mariy-y34
Allahverdi_Мария475