?>
с решением на python3 У каждого жителя на планете Бинариус есть своя электронная тетрадь. В нее записываются будущие дела по мере их поступления. Записи в этой тетради не всегда идут в нужном порядке. Из-за этого кто-то из жителей может пропустить какое-нибудь важное событие.Вам даны записи из одной такой тетради. Напишите программу, которая отсортирует записанные в ней события в хронологическом порядке.Планета Бинариус надеется на вас.Входные данныеПервая строка содержит одно целое число n (1≤n≤10000) — количество записей в тетради.Далее следует n строк с описанием событий. Каждое описание включает время, дату события и краткую информацию о событии.Время события имеет формат «hh:mm», где hh (0≤hh≤23) — часы, mm (0≤mm≤59) — минуты события.Дата события имеет формат «DD.MM.», где DD (1≤DD≤30) — день, MM (1≤MM≤12) — месяц, (2021≤≤9999) — год события. Дата и время каждого события являются уникальными.Часы, минуты, день и месяц события в своей записи всегда имеют два знака.В данной задаче подразумевается, что в одной минуте 60 секунд, в одном часу 60 минут, а один день состоит из 24 часов. Также на планете Бинариус всегда 12 месяцев в году, а каждый месяц состоит ровно из 30 дней.Информация о событии представляет собой непустую строку, состоящую из символов верхнего и нижнего регистров, пробелов, запятых и точек. Длина строки не превышает 100 символов.Выходные данныеВыведите информацию о событиях в хронологическом порядке.Примервходные данные312:59 05.12.2024 Throw out the trash20:40 01.05.2024 To go shopping.12:13 12.06.2023 Pass the unified state exam, выходные данныеPass the unified state exam, To go shopping.Throw out the trash
Ответы
begin
var a:=ArrRandomReal(15,-10,10); a.Println; Writeln;
var m:=a.IndexMax;
var n:=a.IndexMin;
if m>n then (m,n):=(n,m);
var b:=a[m+1:n]; b.Println;
if b.Length>0 then Writeln('П=',b.Aggregate(1.0,(p,x)->p*x))
else Writeln('Нет элементов между минимумом и максимумом')
end.
Тестовое решение:
8.14904220316049 -7.97861530351388 6.22268662612079 -4.04729378132489 -1.70455696606289 2.5380224606665 9.52389909863653 6.96433030858838 3.31410986991325 4.31776128444716 -3.9021073439634 -1.69448156454343 -8.68306868648299 7.89553786529952 -0.403709360586344
6.96433030858838 3.31410986991325 4.31776128444716 -3.9021073439634 -1.69448156454343
П=658.932534926112