manager6
?>

Вводится строка, содержащая существительное 1-го склонения, оканчивающееся на «а». Составьте программу, склоняющую это слово по падежам.​

Информатика

Ответы

Vadim443

var a: string;

begin

write ('Введите слово: '); read (a);

writeln ('Именительный падеж: ',copy(a,1,length(a)));

writeln ('Родительный падеж: ',copy(a,1,length(a)-1),'ы');

writeln ('Дательный падеж: ',copy(a,1,length(a)-1),'е');

writeln ('Винительный падеж: ',copy(a,1,length(a)-1),'у');

writeln ('Творительный падеж: ',copy(a,1,length(a)-1),'ой');

writeln ('Предложный падеж: ',copy(a,1,length(a)-1),'е');

end.

Основной момент, это удаление окончания путем копирования слова в строке a начиная с первого символа, до длины слова минус 1 символ.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вводится строка, содержащая существительное 1-го склонения, оканчивающееся на «а». Составьте программу, склоняющую это слово по падежам.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

aidapiltoyan43
uksusoval617
Владимирович_Ралина
amxvel7596
koxhulya61
dimoni86
kayrina
cosmetic89
ren7869
aifbon
Владимир
vkaloshin
dobrovolsky-tmz1
endyurans2ooo
bruise6