praktikadok
?>

Задачи по теме циклов, есть сомнения что температуру и объем нужно находить через цикл. Посмотрите, возможно ли это и проверьте мою программу. 1. Напишите программу, которая просит ввести температуру по Цельсию, переводит температуру по Цельсию в температуру по Фаренгейту и печатает результаты. Программа должна работать до тех пор, пока не будет введено число меньшее -273. (TF=9/5*TC+32 Перевод температур оформите в виде вс функции, при описании программы опишите интерфейс вс функции. 2. Оформите приводимую ниже программу в виде вс функции и напишите программу, которая просит ввести радиус шара и печатает соответствующий объём шара. Цикл должен работать до тех пор, пока не будет введено отрицательное число. r=3 v = 3/4 * 3.14 * r ** 3 print ("Объём шара равен %.2f" %v) Вычисление объёма оформите в виде вс функции, при описании программы опишите интерфейс вс функции. def temp(tc): for i in range(tc): tf = (9 / 5) * tc + 32 return tf def main(): tc = int(input('Введите температуру в градусах Цельсия: ')) while tc >= -273: tf = temp(tc) print('Температура Цельсия', tc, 'равна', tf, 'градусам Фаренгейта.') tc = int(input('Введите температуру в градусах Цельсия: ')) main()

Информатика

Ответы

vadimkayunusov

def convert(temp):

   return (9 / 5) * temp + 32

def main():

   temp_c = 0

   while temp_c > -273:  # пока введённое число больше -273

       temp_c = int(input('Введите температуру в градусах Цельсия: '))

       temp_f = convert(temp_c)

       print(f'Температура Цельсия {temp_c} равна {temp_f} градусам Фаренгейта.\n')

main()

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задачи по теме циклов, есть сомнения что температуру и объем нужно находить через цикл. Посмотрите, возможно ли это и проверьте мою программу. 1. Напишите программу, которая просит ввести температуру по Цельсию, переводит температуру по Цельсию в температуру по Фаренгейту и печатает результаты. Программа должна работать до тех пор, пока не будет введено число меньшее -273. (TF=9/5*TC+32 Перевод температур оформите в виде вс функции, при описании программы опишите интерфейс вс функции. 2. Оформите приводимую ниже программу в виде вс функции и напишите программу, которая просит ввести радиус шара и печатает соответствующий объём шара. Цикл должен работать до тех пор, пока не будет введено отрицательное число. r=3 v = 3/4 * 3.14 * r ** 3 print ("Объём шара равен %.2f" %v) Вычисление объёма оформите в виде вс функции, при описании программы опишите интерфейс вс функции. def temp(tc): for i in range(tc): tf = (9 / 5) * tc + 32 return tf def main(): tc = int(input('Введите температуру в градусах Цельсия: ')) while tc >= -273: tf = temp(tc) print('Температура Цельсия', tc, 'равна', tf, 'градусам Фаренгейта.') tc = int(input('Введите температуру в градусах Цельсия: ')) main()
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

olesyadeinega41
lenacari
yusovd291
Garifovich Greshilova791
Дарья16
artmasterstyle
gurina50
tumanowivan2015509
proporcia46
mrvasilev2012
komolovda
Rufilya-Belov
rytikovabs
bestform
ВадимСмирнов116