rastockin8410
?>

Заданы два отрезка [a, b] и [c, d]. Составить программу присвоения переменной P значения 1, если точка x принадлежит одновременно первому и второму отрезкам, и значение 0 в противном случае. Печатать x, P, a, b, c, d. Написать программу на Паскале

Информатика

Ответы

Natacha3636672

#include <iostream>

#include <cstdlib>

#include <ctime>


int main()

{

   std::srand(std::time(NULL));


   unsigned short int

       number,

       value,

       _value,

       correct = 0;

   std::cout << "Введите число, умножение на которое будет происходить, и кол-во вопросов: ";

   std::cin >> number >> value;


   _value = value;

   while(_value > 0)

   {

       unsigned int

           _number,

           tmp = 1 + std::rand() % 10;

       std::cout << number << " * " << tmp << " = ";

       std::cin >> _number;

       if(_number == tmp * number)

       {

           std::cout << "Верно." << std::endl;

           correct++;

       }

       _value--;

   }

   std::cout << "Процентное соотношение: " << 100 * (static_cast<float>(correct) / value) << "%."

       << std::endl;

}


1) написать программу, которая предлагает пользователю пройти тест на знание таблицы умножения. для

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Заданы два отрезка [a, b] и [c, d]. Составить программу присвоения переменной P значения 1, если точка x принадлежит одновременно первому и второму отрезкам, и значение 0 в противном случае. Печатать x, P, a, b, c, d. Написать программу на Паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

hbqhzwtd
Остап-Лаврова1410
mskatrinmadness
Vitproficosmetics
Dmitrii1763
anna241273
Жуков219
nataljatchetvertnova
Филиппович_Николаевич
Belov Yekaterina639
janetp
margo929
gallows-warlike-0z
alina-bas
andr77716
▲