НАДО Составить программу, которая выводит на экран фамилию и имя с применением оператора цикла с предусловием и оператора цикла с постусловием. Условие выбираете самостоятельно
var a: array[1..n, 1..n] of integer; i, j, m, nmax, nmin, jmax, jmin: integer;
begin Randomize; writeln('Исходный массив'); for i := 1 to n do begin nmax := -100; nmin := 100; for j := 1 to n do begin a[i, j] := Random(24) - 8; if nmax < a[i, j] then begin nmax := a[i, j]; jmax := j end; if nmin > a[i, j] then begin nmin := a[i, j]; jmin := j end; write(a[i, j]:4) end; writeln; a[i, jmax] := nmin; a[i, jmin] := nmax end; writeln(#13#10, 'Результирующий массив'); for i := 1 to n do begin for j := 1 to n do write(a[i, j]:4); writeln end end.
n = 5;
var
a: array[1..n, 1..n] of integer;
i, j, m, nmax, nmin, jmax, jmin: integer;
begin
Randomize;
writeln('Исходный массив');
for i := 1 to n do
begin
nmax := -100;
nmin := 100;
for j := 1 to n do
begin
a[i, j] := Random(24) - 8;
if nmax < a[i, j] then
begin
nmax := a[i, j];
jmax := j
end;
if nmin > a[i, j] then
begin
nmin := a[i, j];
jmin := j
end;
write(a[i, j]:4)
end;
writeln;
a[i, jmax] := nmin;
a[i, jmin] := nmax
end;
writeln(#13#10, 'Результирующий массив');
for i := 1 to n do
begin
for j := 1 to n do write(a[i, j]:4);
writeln
end
end.
Тестовое решение:
Исходный массив
-4 8 3 7 5
-7 -7 1 8 0
14 0 0 1 -1
14 7 -5 -1 14
7 6 1 -6 14
Результирующий массив
8 -4 3 7 5
8 -7 1 -7 0
-1 0 0 1 14
-5 7 14 -1 14
7 6 1 14 -6