составить программу для вычисления значения функции f(x)=x-sin x на отрезке {a, b} с шагом c. Результат представить в виде таблицы, первый столбец который - значения аргумента, второй- соответствующие значения функции. Нужно на паскале
Var n,i,j,resi,resj,flag:integer; begin flag:=0; i:=1; readln(n); while power(i,3)<n do begin j:=1; while power(j,3)+power(i,3)<=n do begin if power(j,3)+power(i,3)=n then begin flag:=1; resi:=i; resj:=j; break; end; inc(j); end; if flag=1 then break; inc(i); end; if flag=1 then writeln(resi,' ',resj,' ',resj,' ',resi) else writeln('impossible'); end.
Пример ввода: 1008 //2^3+10^3 Пример вывода: 2 10 10 2
Var
n,i,j,resi,resj,flag:integer;
begin
flag:=0;
i:=1;
readln(n);
while power(i,3)<n do
begin
j:=1;
while power(j,3)+power(i,3)<=n do
begin
if power(j,3)+power(i,3)=n then
begin
flag:=1;
resi:=i;
resj:=j;
break;
end;
inc(j);
end;
if flag=1 then break;
inc(i);
end;
if flag=1 then writeln(resi,' ',resj,' ',resj,' ',resi) else writeln('impossible');
end.
Пример ввода:
1008 //2^3+10^3
Пример вывода:
2 10 10 2