rusmoney92
?>

Написать программу на пайтоне Четыре точки заданы своими координатами X(x1, x2, x3), Y(y1, y2, y3), Z(z1, z2, z3), T(t1, t2, t3 Выяснить, какие из них находятся на минимальном расстоянии друг от друга и вывести на экран значение этого расстояния. Вычисление расстояния между двумя точками оформить в виде процедуры.

Информатика

Ответы

katrin819

#include <iostream>

#include <vector>

using namespace std;

void solve(){

   int m,n;

   cin >> m >> n;

   vector<vector<int>> a(m,vector<int>(n));

   vector<bool> b(m, true);

   for(int i = 0; i < m; i++)

       for(int j = 0; j < n; j++)

           cin >> a[i][j];

   for(int i = 0; i < m; i++)

       for(int j = 1; j < n; j++)

           if(a[i][j] <= a[i][j-1])

               b[i] = false;

   for(auto i : b) cout << i << " ";

}

signed main(){

   solve();

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на пайтоне Четыре точки заданы своими координатами X(x1, x2, x3), Y(y1, y2, y3), Z(z1, z2, z3), T(t1, t2, t3 Выяснить, какие из них находятся на минимальном расстоянии друг от друга и вывести на экран значение этого расстояния. Вычисление расстояния между двумя точками оформить в виде процедуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Мария
llmell6
airlineskozlova69
DVOct33
zabrodin
menametov
dksvetlydir
palosik7621
Мария-Кострыгина175
Yevgenevna
artemka56rus
re-art
mariy-inkina8
Alyona
ВалентиновичСуриковна1104
Aнaлитикaлық мaшинaAнaлитикaлық мaшинa