Nastyakarysheva8750
?>

создайте поле размером 7х7. составьте программу, в результате которой робот закрасит диагональные клетки поля.исходное положение робота и результат выполнения программы показаны на рисунке 3.34

Информатика

Ответы

natalyaionova

вот 3 варианта решения задачи:

1. с временной целочисленной переменной вместо булеан.

var

   a, f : integer;

begin

   write('введите число: ');

   readln(a);

   while a div 10 > 0 do begin

       if (a mod 10) >= ((a mod 100) div 10) then f := 1;

       a := a div 10;

   end;

   if f = 0 then writeln('ДА') else writeln('НЕТ');

end.

2. с строчной переменной которой присваивается текст ответа.

var

   a : integer;

   f : string := 'ДА';

begin

   write('введите число: ');

   readln(a);

   while a div 10 > 0 do begin

       if (a mod 10) >= ((a mod 100) div 10) then f := 'НЕТ';

       a := a div 10;

   end;

   writeln(f);

end.

3. без дополнительных переменных но с оператором break.

var

   a : integer;

begin

   write('введите число: ');

   readln(a);

   while a div 10 > 0 do begin

       if (a mod 10) >= ((a mod 100) div 10) then begin

           writeln('НЕТ');

           break;

       end;

       a := a div 10;

       if a < 10 then writeln('ДА');

   end;

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

создайте поле размером 7х7. составьте программу, в результате которой робот закрасит диагональные клетки поля.исходное положение робота и результат выполнения программы показаны на рисунке 3.34
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vetroff-11
igor8809337
olesya-kwas
Simbireva
evoque2014
X2755070
ShafetdinovAndrei
mila-vsv
manimen345
infosmolenskay
emmakazaryan290
NIKOLAI
festjob
Исмагилова_Саният
Михайлович Гуртовая929