Peshkov
?>

Составьте программу, сортирующую целочисленный массив по убыванию методом простого выбора.

Информатика

Ответы

Voronina747
Решение №1 (без массивов)

var a,n,i,j,s:integer;
begin
  writeln('Введите количество цифр в числе');
  readln(n);
  for i:=1 to n do begin
    writeln('Введите ',i,' цифру из ',n);
    readln(a);
    for j:=1 to n-i do a:=a*10;
    s:=s+a;
  end;
  writeln('Натуральное число: ',s);
end.

Тестовое решение

Введите количество цифр в числе
5
Введите 1 цифру из 5
9
Введите 2 цифру из 5
2
Введите 3 цифру из 5
7
Введите 4 цифру из 5
3
Введите 5 цифру из 5
1
Натуральное число: 92731

Решение №2 Если очень надо использовать массив (хотя на мой взгляд совсем не нужно)

//PascalABC.NET (версия 3.1, сборка 1198)
var a,n,i,j,s:integer;
mas:array[1..10]of integer;
begin
  writeln('Введите количество цифр в числе');
  readln(n);
  for i:=1 to n do begin
    writeln('Введите ',i,' цифру из ',n);
    readln(mas[i]);
    a:=mas[i];  
    for j:=1 to n-i do a:=a*10;
    s:=s+a;
  end;
  writeln('Натуральное число: ',s);
end.

Тестовое решение

Введите количество цифр в числе
5
Введите 1 цифру из 5
5
Введите 2 цифру из 5
4
Введите 3 цифру из 5
3
Введите 4 цифру из 5
2
Введите 5 цифру из 5
2
Натуральное число: 54322

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, сортирующую целочисленный массив по убыванию методом простого выбора.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pechatlogo4
А Дзукаев1562
delena6467
ermisyareg436
mouse-0211fsb3509
prokodasha
kosstroy
alex07071
gamolml
Алина Ракитин1730
larisau41
igor-790
Андреевнатест707
papanovar
knyazev527