Lyudmila-Popova
?>

Составьте программу, которая меняет местами максимальный и минимальный элементы массива и выводит на экран исходный и преобразованный массивы. Все элементы массива различны, и их значения вводятся с клавиатуры.

Информатика

Ответы

komarov-dmitriy

#include <iostream>

#include <iomanip>

#include <ctime>

using namespace std;

int main()

{

   setlocale(LC_ALL, "russian");

   int max = 0;

   int min = 0;

   int Indexmin2;

   int Indexmax = 0, Indexmin = 0;

   const int N = 10;

   int array[N];

   int i;

   for (i = 0; i < N; i++)

   {

       cin >> array[i];

   }

   cout << endl;

   cout << " Результат до перестановки " << endl;

   for (i = 0; i < N; i++)

   {

       cout << setw(5) << array[i];

   }

   cout << endl;

   cout << " Результат после перестановки " << endl;

   for (i = 0; i < N; i++)

   {

       if (array[i] > max)

       {

           max = array[i];

           Indexmax = i;

       }

       if (array[i] < min)

       {

           min = array[i];

           Indexmin = i;

       }

   }

   Indexmin2 = array[Indexmin];

   array[Indexmin] = array[Indexmax];

   array[Indexmax] = Indexmin2;

   for (i = 0; i < N; i++)

   {

       cout << setw(5) << array[i];

   }

   cout << endl;

   cout << "Максимальное: " << max << endl;

   cout << "Минимальное: " << min << endl;

   cout << "Максимальный индекс: " << Indexmax << endl;

   cout << "Минимальный индекс: " << Indexmin << endl;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая меняет местами максимальный и минимальный элементы массива и выводит на экран исходный и преобразованный массивы. Все элементы массива различны, и их значения вводятся с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Дмитрий-Олейникова
ogonizoloto
tooltechnic
ddobrov32133
ktatarinova
anna-ditman
Владислав893
teregorka1977205
mustaevdmitry397
chulki-kupit
АндреевичОльга641
Алёна Геннадьевна98
agafonovalyudmila346
Stepanovich_Makarov
best00