koam20167459
?>

Для решения задачи С 14 Петя составил алгоритм и записал программу. Петя младший брат Олег удалил несколько команд. Определите, сколько команд удалил Олег. Восстановите программу, которую написал Петя

Информатика

Ответы

Ерохин

import random

class Passanger:

   def __init__(self, name_pass, bagadge_value, bagadge_quantity):

       """Constructor"""

       self.name_pass = name_pass

       self.bagadge_value = bagadge_value

       self.bagadge_quantity = bagadge_quantity

if __name__ == "__main__":

   list_name_pass = ["Иванов","Иванова","Калдыбег","Мухутдинов","Карелов","Анакондов"]

   list_bagadge_value = [25,1,4,14,29,35,2,4,25,6,25,3]

   list_bagadge_quantity = [1,4,5,1,1,1,1,1,1,4]

   list_passangers = []

   random.shuffle(list_name_pass)

   random.shuffle(list_bagadge_value)

   random.shuffle(list_bagadge_quantity)

   for i in range(len(list_name_pass)):

       list_passangers.append(Passanger(list_name_pass[i],list_bagadge_value[i], list_bagadge_quantity[i]))

   print("Подходят под условие:")

   for i in list_passangers:

       if (i.bagadge_value < 25 and i.bagadge_quantity == 1):

           print(i.name_pass, i.bagadge_value, i.bagadge_quantity)

   print("")

   print("Пассажиры:")

   for i in list_passangers:

       print(i.name_pass, i.bagadge_value, i.bagadge_quantity)

Объяснение:

https://pastebin.com/hNT2m49y

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Для решения задачи С 14 Петя составил алгоритм и записал программу. Петя младший брат Олег удалил несколько команд. Определите, сколько команд удалил Олег. Восстановите программу, которую написал Петя
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

cleopatra1959
arevik2307
potemkin77
Chervonnaya-Aleksei
krasilnikov74
Овсянкина407
treneva359
kris5009646
chuev4444
ИП-Сысоев1628
AndreiAstakhva1442
azarovaelena19812
julianikaleksandrova
Immortal3331
Бочкарева Горохова1652
▲