houseoftorture138
?>

Паскаль абс Дан массив из 10 целых чисел. Найдите максимальный элемент этого массива и выведите его на экран.​

Информатика

Ответы

evoque2014

#include <iostream>  //подключаем библиотеки

using namespace std; //пространство имён

int main() {

 

setlocale(LC_ALL, "Russian");

 

int tableInt;  //последовательность

int x;   //икс :)

bool ZaB = true;  //бул для красоты

 

cout << "Введите переменную X: "; cin >> x;  //просим X

cout << "Введите последовательность через пробел: ";  //последовательность

 

while(cin >> tableInt)   //цикл

{

 if(ZaB)  //для красоты

 {

  cout << "Результат: ";

  ZaB = false;

 }

 if(tableInt != 0 && tableInt > x)  //вывод того, что больше

 {

  cout << tableInt << " ";  //если ноль, то конец!

 }else if(tableInt == 0)

 {

  break;

 }

}

 

return 0; //возращаем ничего

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль абс Дан массив из 10 целых чисел. Найдите максимальный элемент этого массива и выведите его на экран.​
Ваше имя (никнейм)*
Email*
Комментарий*