vbnm100584
?>

Составить программу, вычисляющую следующие величины: E=mc^2 Программу нужно составить в полном виде Pascal.ABC.NET

Информатика

Ответы

red-sun2
Задача 1.
var
  f:Text;
  n,nmax,nmin:integer;
begin
  Assign(f,'input.txt'); Reset(f);
  nmax:=-32786; nmin:=32767; {границы представления integer}
  while not Eof(f) do begin
    Readln(f,n);
    if (n>0) and (n mod 2=0) then
      if nmax<n then nmax:=n
      else
        if nmin>n then nmin:=n
  end;
  Close(f);
  Assign(f,'output.txt'); Rewrite(f);
  Writeln(f,nmin,' ',nmax);
  Close(f)
end.

Задача 2.
const
  m=100; { максимальное количество чисел в файле }
var
  f:Text;
  i,j,n,k:integer;
  a:array[1..m] of integer;
begin
  { читаем данные из файла в массив }
  Assign(f,'input.txt'); Reset(f);
  i:=0;
  while not Eof(f) do begin Inc(i); Readln(f,a[i]) end;
  Close(f);
  n:=i;
  { сортируем массив по возрастанию методом пузырька }
  for i := 1 to n-1 do
    for j := 1 to n-i do
      if a[j] > a[j+1] then
      begin k := a[j]; a[j] := a[j+1]; a[j+1] := k end;
  { заполняем файл из массива }
  Assign(f,'output.txt'); Rewrite(f);
  for i:=1 to n do Writeln(f,a[i]);
  Close(f)
end.

Вложение: пример файла input.txt

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, вычисляющую следующие величины: E=mc^2 Программу нужно составить в полном виде Pascal.ABC.NET
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

skvik71672
info36
elenak26038778
Serdechnaya636
aidapiltoyan43
nkochladze
kostavaani
zakaz
Sakmarov
Sharmel26
LIN1022
Коновалова1705
Anna-Miron
mikhail
tatarinova-51