coffee2201
?>

Дано четырехзначное целое число. Написать программу, которя выводить цыфры из которых состоит это число ? Пример входных данных: 5221 Пример входных данных: 5, 2, 2, 1

Информатика

Ответы

salesrawtogo
#include <iostream>
#include <iomanip>
using namespace std;

int main() {
      int n;
      cout<<"n = ";  cin>>n;   // ввод количества элементов массива 
      int a[n];
// заполнение массива и вывод на экран
      for (int i=0;i<n;i++) { 
           a[i]=rand()%15;     cout<<a[i]<<" "; 
      } 
      cout<<endl;  // перевод строки
// сортировка массива по возрастанию
      for (int i=0; i<n-1; i++)
      for (int j=i+1; j<n; j++) 
           if (a[i]>a[j]) swap(a[i],a[j]);
// вывод 4 минимальных
      cout<<"four min numbers:  ";
      for (int i=0; i<4; i++)  cout<<a[i]<<" ";
      cout<<endl;
      system("pause");  // ожидание ввода с клавиатуры
      return 0;
  }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано четырехзначное целое число. Написать программу, которя выводить цыфры из которых состоит это число ? Пример входных данных: 5221 Пример входных данных: 5, 2, 2, 1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mgrunova
ooo-helpvet44
dumpler
novkatrina
zaschitin48
Джулия
lazu8375
hellomaxim
Коваль1974
Виталий
loa364
olga0909196323
volkovaoksana19806037
kulikovtsud
alex07071