katrin819
?>

Напишите программу на паскале Дано неотрицательное целое N. Найти сумму и количество цифр в системе счисления с основанием q. q=2

Информатика

Ответы

ksvish2012

var

 i, p, n, q, sum: integer;

 a : array[1..1000000] of byte;

begin

 Write('Введите число N: ');

 ReadLn(n);

 Write('Введите основание системы счисления q: ');

 ReadLn(q);

 p := n;

 while p > 0 do

   begin

     i := i + 1;

     a[i] := p mod q;

     sum := sum + a[i];

     p := p div q;

   end;

 Write(n,'(10) = ');

 for p := i downto 1 do

   Write(a[p]);

 WriteLn('(', q, ')');

 WriteLn('Сумма цифр полученного числа равна ', sum);

 WriteLn('Количество цифр полученного числа равна ', i);

end.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на паскале Дано неотрицательное целое N. Найти сумму и количество цифр в системе счисления с основанием q. q=2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

strelnikov-aa
dvbbdv4
Galinova2911
yocrew13
Valerii276
ivanlimeexpo
Segyn1218
baranova302
Fedorovich309
mariy-y34
Ivan1568
ajsklan
AHO436
teta63
gulnaradjhumabaeva123
▲