Поделитесь своими знаниями, ответьте на вопрос:
Чтобы получить приглашение в самый крутой лагерь на Земле, необходимо попасть в десятку первых на олимпиаде или же успешно написать тесты по математике и русскому языку. Напишите программу, которая определяет, пригласят ли Вас в лагерь по данным: написали ли Вы олимпиаду, хорошо ли сдали экзамены по математике и русскому языку.Формат входных данныхПрограмме подаётся на вход 4 целых числа, записанные через пробел: * место в рейтинговой таблице олимпиады, * набранный на тесте по математике, * проходной теста по математике * «1», если тест по русскому языку пройден и «0» в противном случае. Первые три числа входных данных находятся в диапазоне от 0 до 1000 включительно.Формат выходных данныхТребуется вывести «YES», если Вы получите приглашение в самый крутой лагерь на Земле и «NO» в противном случае.входные данные1 5 7 1 выходные данные YES
Если числа из условия записаны в переменные rank, score, passingScore, russianLanguage, то получение можно получить, если:
rank ≤ 10 или score ≥ passingScore и russinaLanguage = 1
В C++ ИЛИ обозначается как ||, а И - как &&.
Код (C++):
#include <iostream>
int main() {
int rank, score, passingScore, russianLanguage;
std::cin >> rank >> score >> passingScore >> russianLanguage;
if ((rank <= 10) || ((score >= passingScore) && (russianLanguage == 1))) {
std::cout << "YES";
} else {
std::cout << "NO";
}
}