?>
                
Здравствуйте с информатикой. Надо написать программу в Паскале. Задача: Вычислить значение функции. Осуществить вывод значений исходных данных и результат вычисления значений функции, сопровождая вывод наименованиями переменных. Кто разбирается
              
              
              
                
Ответы
                
              
              
             
            
          
program z1;
var a,b,x,y:real;
begin
a:=2.6;
b:=-0.39;
x:=0.8;
while x<=2 do
begin
if x<2.8 then y:=(a+b)/(exp(x) + cos(x))
else if x>=6 then y:=exp(x) + sin(x)
else y:=(a+b)/(x+1);
writeln('x = ',x,' y = ',y:0:3);
x:=x+0.5
end
end.
Объяснение:
Заданы значения a, b и x
Цикл с предусловием (пока x<=2), выполняем действия:
1) проверяем условие по какой формуле следует считать y и считаем его
2) выводим на экран текущие значения x и y
3) увеличиваем x на шаг