artem
?>

Задача: Дано целое число N. Написать программу, заменяющую его нулем, если число меньше нуля и увеличивающую его на 4, если число больше либо равно нулю . В ПАСКАЛЕ

Информатика

Ответы

slavutich-plus2

begin

 var N := readinteger;

 if (N < 0) then

   N := 0

 else

   inc(N, 4);

 write(N);

end.

Объяснение:

begin  // Начало программы

 var N := readinteger;  // Считываем значение переменной N с клавиатуры

 if (N < 0) then  // Если значение переменной N < 0, тогда

   N := 0  // Значение переменной N = 0

 else  // Иначе

   inc(N, 4);  // Увеличиваем значение переменной N на 4

 write(N);  // Выводим значение переменной N

end. // Конец программы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задача: Дано целое число N. Написать программу, заменяющую его нулем, если число меньше нуля и увеличивающую его на 4, если число больше либо равно нулю . В ПАСКАЛЕ
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

asskokov
baltgold-m27
tigo1
pizzaverona
lzelenyi5
elena-ruzadom
aetolstih
ВостриковаСтародубцева1980
machkura
plv-57
Евгеньевич Балиловна1398
ckiras9
Ignateva737
pavlino-mkr
yuraotradnov