?>
1.Даны три числа .возвести в квадрат те из них, значение которых отрицательны и найти их суммуПаскаль) 2.Составить программу , реализующую эпизод сказки: Спрашивает .куда предпочитает пойти гурой (Налево, направо или прямо) и печатает , что его ждет в каждом случае
Ответы
int perva, pervb, pervv;
int vtora, vtorb, vtorv;
Console.WriteLine("Введите длину первого ящика");
perva = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите ширину первого ящика");
pervb = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите высоту первого ящика");
pervv = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите длину второго ящика");
vtora = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите ширину второго ящика");
vtorb = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите высоту второго ящика");
vtorv = Convert.ToInt32(Console.ReadLine());
int result;
int result2;
result = perva * pervb * pervv;
result2 = vtora * vtorb * vtorv;
obratno:
if (result > result2)
{
int anotherresult;
anotherresult = result2 * 2;
goto obratno;
}
if (result < result2)
{
int anotherresult2;
anotherresult2 = result * 2;
goto obratno;
}