happych551
?>

1.Составить программу, которая выводит сообщение о своих возможностях : Введите номер необходимой функции: 1-квадрат; 2-корень квадратный; 3-синус; 4-косинус и считает соответствующую функцию для введённого с клавиатуры числа.

Информатика

Ответы

marinamarinazmeeva2444

#include <iostream>

#include <cmath>

#include <conio.h>

using namespace std;

int main() {

   cout << "Введите номер необходимой функции:\n1-квадрат; 2-корень квадратный; 3-синус; 4-косинус\n";

   char c;

   cin >> c;

   // Если используешь обычный компилятор (не онлайн), можно написать "char c = _getch()";

   

   cout << "Введите число: \n";

   int num;

   cin >> num;

   

   switch(c) {

       case '1':

           cout << pow(num ,2);

           break;

       case '2':

           cout << sqrt(num);

           break;

       case '3':

           cout << sin(num);

           break;

       case '4':

           cout << cos(num);

           break;

       default:

           cout << "Ошибка ввода";

   }

   return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1.Составить программу, которая выводит сообщение о своих возможностях : Введите номер необходимой функции: 1-квадрат; 2-корень квадратный; 3-синус; 4-косинус и считает соответствующую функцию для введённого с клавиатуры числа.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Maksim Dmitrii1579
Геннадьевна Вета560
platonovkosty
Avetisyan575
Korobeinikov-Yulich23
purchase
kolgatin69
tatianamatsimoh
volchek01112240
Dodkhobekovich1683
andy74rus36
anovikovsr
Шиморянов Мария1866
александр496
alexfold