yurazharov
?>

Введите с клавиатуры 5 положительных целых чисел. Вычислите сумму тех из них, которые делятся на 4 и при этом заканчиваются на 6. Программа должна вывести одно число: сумму чисел, введенных с клавиатуры, кратных 4 и оканчивающихся на 6. Пример работы программы: Входные данные 12 16 36 26 30 Выходные данные 52 сделать это на паскале

Информатика

Ответы

Dms161964937

Текущее значение суммы сохраним в переменной s, в начале s = 0.

В цикле 5 раз считаем с клавиатуры число, если оно кратно 4 и оканчивается на 6 (иначе говоря, если остаток от деления на 4 равен нулю, а остаток от деления на 10 равен 6), то увеличиваем s на введенное число.

В конце выводим значение переменной s.

Код (Pascal):

var

 i, s, temp: integer;

begin

 s := 0;

 for i := 1 to 5 do

 begin

   read(temp);

   if (temp mod 4 = 0) and (temp mod 10 = 6) then

     s := s + temp;

 end;

 write(s)

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Введите с клавиатуры 5 положительных целых чисел. Вычислите сумму тех из них, которые делятся на 4 и при этом заканчиваются на 6. Программа должна вывести одно число: сумму чисел, введенных с клавиатуры, кратных 4 и оканчивающихся на 6. Пример работы программы: Входные данные 12 16 36 26 30 Выходные данные 52 сделать это на паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

marinazubcko16729
Середа-Сергеенков980
magazin3000
tooltechnic
Dimston134877
Николаевна
Любовь-Волков1205
utburt
novocherkutino7
apetrov54
Тимур
Aleksandr72
utkinslava
Svatela37
pak1998378