Корнеплодович1930
?>

1. Автоморфными называются числа, которые содержатся в последних разрядах их квадрата, например: 52 = 25 62 = 36 Напишите программу для нахождения 10 первых автоморфных чисел. На экран программа должна выводить, как само автоморфное число, так и его квадрат. 2. Парными простыми числами называются два простых числа, разность которых равна двум, например: 3 5; 5 7. Напишите программу нахождения первых 15 таких пар. Желательно использовать break и continue. Нужно сделать 2 задани на языке C, если что мы вот такие темы - break и continue, Оператор повтора for, while и do-while, switch, if-else.

Информатика

Ответы

Yurok9872
Const
  n = 30;

var
  x: array[1..n] of integer;
  i, t, min: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  min:=32767;
  for i := 1 to n do
  begin
    t := Random(1001)-500;
    x[i] := t;
    Write(t:5);
    if Odd(i) and (t mod 5 = 0) and (min>t) then min:=t
  end;
  Writeln;
  Writeln('Минимальный нечетный элемент, кратный 5, равен ',min)
end.

Тестовое решение:
Элементы массива
  -64  438 -290  358 -424  234 -444  -17  171  -57 -373 -279  242 -403 -262   34 -488  365  341 -468  163 -276  193 -140  126 -466 -236  -34  350 -369
Минимальный нечетный элемент, кратный 5, равен -290

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. Автоморфными называются числа, которые содержатся в последних разрядах их квадрата, например: 52 = 25 62 = 36 Напишите программу для нахождения 10 первых автоморфных чисел. На экран программа должна выводить, как само автоморфное число, так и его квадрат. 2. Парными простыми числами называются два простых числа, разность которых равна двум, например: 3 5; 5 7. Напишите программу нахождения первых 15 таких пар. Желательно использовать break и continue. Нужно сделать 2 задани на языке C, если что мы вот такие темы - break и continue, Оператор повтора for, while и do-while, switch, if-else.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vapebroshop
ehrik-ch
Lenuschakova1982316
Korikm
sveta1864
Рогова Ольга1156
yulyaderesh
Ваган Шутова332
shmanm26
superkiosk249
gernovoy
Karpova
Нина1449
Valerevna Tuzova
Михаил1121