Sergei
?>

нужен человек который работает в Паскале . Уровень института . Задание к работе: 1. Выберите задание согласно вашему варианту. 2. Для задания 1 «Цикл с параметром. Нахождение суммы ряда»: a. определить количество переменных и типы данных; b. составить блок-схему решения задачи; c. написать программу на языке Pascal с использованием оператора FOR. 3. Для задания 2 «Цикл с не известным числом повторений. Нахождение суммы ряда»: a. определить количество переменных и типы данных; b. составить блок-схему решения задачи; c. написать программу на языке Pascal с использованием оператор REPEAT или WHILE. 4. Представить на проверку преподавателю блок-схемы и программы. 5. Письменно ответить на контрольные вопросы по теме «Циклический вычислительный процесс».

Информатика

Ответы

Марина555

Сишарпик

           string ArmanAge, IvanAge, RuslanAge;

           Console.WriteLine("Введите возраст Армана."); ArmanAge = Console.ReadLine();

           Console.WriteLine("Введите возраст Ивана."); IvanAge = Console.ReadLine();

           Console.WriteLine("Введите возраст Руслана."); RuslanAge = Console.ReadLine();

           if (byte.TryParse(ArmanAge, out byte ByteArmanAge) && ByteArmanAge < 115 &&

              byte.TryParse(IvanAge, out byte ByteIvanAge) && ByteIvanAge < 115 &&

              byte.TryParse(RuslanAge, out byte ByteRuslanAge) && ByteRuslanAge < 115)

           {

               byte MaxAge;

               byte EqualAge;

               if (ByteArmanAge > ByteIvanAge && ByteArmanAge > ByteRuslanAge)

               {

                   MaxAge = ByteArmanAge;

                   Console.WriteLine($"Самый старший Арман, его возраст {MaxAge}.");

               }

               else if (ByteIvanAge > ByteArmanAge && ByteIvanAge > ByteRuslanAge)

               {

                   MaxAge = ByteIvanAge;

                   Console.WriteLine($"Самый старший Иван, его возраст {MaxAge}.");

               }

               else if (ByteRuslanAge > ByteArmanAge && ByteRuslanAge > ByteIvanAge)

               {

                   MaxAge = ByteRuslanAge;

                   Console.WriteLine($"Самый старший Руслан, его возраст {MaxAge}.");

               }

               else

               {

                   EqualAge = ByteRuslanAge; // к примеру его возраст.

                   Console.WriteLine($"У всех парней одинаковый возраст, им по {EqualAge} лет.");

               }

           }

           else

           {

               Console.WriteLine("Введите корректные значения.");

               Console.ReadLine();

               return;

           }

           Console.ReadLine();

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

нужен человек который работает в Паскале . Уровень института . Задание к работе: 1. Выберите задание согласно вашему варианту. 2. Для задания 1 «Цикл с параметром. Нахождение суммы ряда»: a. определить количество переменных и типы данных; b. составить блок-схему решения задачи; c. написать программу на языке Pascal с использованием оператора FOR. 3. Для задания 2 «Цикл с не известным числом повторений. Нахождение суммы ряда»: a. определить количество переменных и типы данных; b. составить блок-схему решения задачи; c. написать программу на языке Pascal с использованием оператор REPEAT или WHILE. 4. Представить на проверку преподавателю блок-схемы и программы. 5. Письменно ответить на контрольные вопросы по теме «Циклический вычислительный процесс».
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Tamara
Surkova_Pavlovna
Олег86
donertime8
Никита_Тузов
koxhulya61
ermisyareg436
pak1998378
Элизбарян
Гарик383
Anastasiya Yevseeva948
melissa-80
best00
Александрович
okutihamv