Uses Crt; Const N = 15; M = 10; Var A:array[1..N,1..M] of real; i,j:integer; S3,S7:real; Begin Randomize; ClrScr; WriteLn('Исходный массив:'); For i:= 1 to N do Begin For j:= 1 to M do Begin A[i,j]:=random*13; Write(A[i,j]:6:3,' ') End; WriteLn End; S3:=0; S7:=0; For j:= 1 to M do Begin S3:=S3+A[3,j]; S7:=S7+A[7,j]; End; WriteLn('S3 = ',S3:0:3); WriteLn('S7 = ',S7:0:3); if S3 > S7 then WriteLn('S3 > S7') else if S3 < S7 then WriteLn('S3 < S7') else WriteLn('S3 = S7'); ReadLn End.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу вывода на экран фразы “ХХХХХХХХ-выдающийся ученый ХХ века”. Фамилия ученого ХХХХХХХХ вводится с клавиатуры.
Const
N = 15;
M = 10;
Var
A:array[1..N,1..M] of real;
i,j:integer;
S3,S7:real;
Begin
Randomize;
ClrScr;
WriteLn('Исходный массив:');
For i:= 1 to N do
Begin
For j:= 1 to M do
Begin
A[i,j]:=random*13;
Write(A[i,j]:6:3,' ')
End;
WriteLn
End;
S3:=0;
S7:=0;
For j:= 1 to M do
Begin
S3:=S3+A[3,j];
S7:=S7+A[7,j];
End;
WriteLn('S3 = ',S3:0:3);
WriteLn('S7 = ',S7:0:3);
if S3 > S7 then WriteLn('S3 > S7')
else if S3 < S7 then WriteLn('S3 < S7')
else WriteLn('S3 = S7');
ReadLn
End.