Андрей
?>

Сделайте Написать программу нахождения суммы и среднего арифметического значения элементов целочисленного массива размерностью n. С одномерного массива. n равен количеству букв в вашем имени (например, Лев - размерность 3, или Вероника - размерность 8) *размерность - количество элементов массива

Информатика

Ответы

ktv665

#include <iostream>

using namespace std;

int main() {

srand(time(NULL));

string s;

int n;

float sum=0;

cin>> s;

n= s.length();

int a[n];

for(int i=0;i<n; i++)

{a[i]= random()%10;

sum+=a[i];

cout<<a[i]<<" ";

}

cout<<endl<<"Сумма всех элементов = "<<sum;

float sum1= sum/n;

cout<<endl<<"Среднее арифметическое = "<<sum1;

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сделайте Написать программу нахождения суммы и среднего арифметического значения элементов целочисленного массива размерностью n. С одномерного массива. n равен количеству букв в вашем имени (например, Лев - размерность 3, или Вероника - размерность 8) *размерность - количество элементов массива
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

irschacha
info-mosbalkon
artashhovhan
Анатольевич-Лариса
mariy-inkina8
bezpalova2013
verkop9
mursvita943
Mydariamiro
Бирюков Карпова1379
bryzgalovag
Державина
mariyachervonnaya44
Mikhail1369