grachevakaterina
?>

составить программу С++, используя оператор FOR. 1 У гусей и кроликов вместе 64 лапы. Сколько может быть кроликов и гусей (указать все сочетания и количество вариантов)? 2 Составить программу, используя оператор FOR. Составить программу для определения N! – M!, где N!=1*2*3*…*. N . N и М задает пользователь

Информатика

Ответы

tkmandarin8376

1)

#include <iostream>

using namespace std;

int main()

{

int g, k, n=64;

for (g=0; g<=n; g++)

{

for (k=0; k<=n/2; k++)

{

if (2*g + 4*k == n)

{

printf ("Gycu - %d. \nKpoluk - %d.\n\n", g, k);

}

}

}

return 0;

}

2)#include <iostream>

using namespace std;

long double fact(int N)

{

if(N < 0)

return N;

if (N == 0)

return 1;

else

return N * fact(N - 1);

}

int main()

{

int N, M;

setlocale(0,"");

cout << "N=";

cin >> N;

cout<<"M=";

cin>>M;

cout<<"N!-M!=" << fact(N)-fact(M) << endl << endl;

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

составить программу С++, используя оператор FOR. 1 У гусей и кроликов вместе 64 лапы. Сколько может быть кроликов и гусей (указать все сочетания и количество вариантов)? 2 Составить программу, используя оператор FOR. Составить программу для определения N! – M!, где N!=1*2*3*…*. N . N и М задает пользователь
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

horina12
yusliva
JisesLove19955
Bella
zatoichi69
Dimston134877
artashhovhan
best00
Александра Викторович531
yliana
Irina1435
Максим_Нина
jim2k
dream2366
koxhulya61