Лихачев Полина1978
?>

Напишите программу в C++: Найти сумму и количество целых чисел больших 20, меньших 200 и кратных 3. Вывести числа, удовлетворяющие условию, их количество, найденную сумму, среднее арифметическое. Вывести числа, заканчивающиеся на 0.

Информатика

Ответы

andreevaalisa

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   float summa, count = 0;

   vector<int> result, zero;

   for (int i = 21; i < 200; i++)

   {

       if (i % 3 == 0)

       {

           result.push_back(i);

           count++;

           summa += i;

           if (i % 10 == 0)

           {

               zero.push_back(i);

           }

       }

   }

   cout << R"(Числа которые заканчиваютса нулем )" << endl;

   for (int i = 0; i < zero.size(); i++)

   {

       cout << zero[i] << ' ';

   }

   cout << endl;

   cout << R"(Числа которые кратные 3)" << endl;

   for (int i = 0; i < result.size(); i++)

   {

       cout << result[i] << ' ';

   }

   cout << endl;

   cout << R"(Количество таких чисел = )" << count << endl;

Дальше немного сами подумайте если я это написал и вы это не поняли. Советую учить С++. Потому что вы не будете понимать что вы делаете.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в C++: Найти сумму и количество целых чисел больших 20, меньших 200 и кратных 3. Вывести числа, удовлетворяющие условию, их количество, найденную сумму, среднее арифметическое. Вывести числа, заканчивающиеся на 0.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Суховодова599
alexandrxzx09
mikchaylovaalex
mupmalino2653
svetkinm158
aprelevka
Yurevna_Kharkchinov1302
Vyacheslavovna1867
ksenyabobrovich7214
ohussyev
Veselova
armsam76
Yekaterina
mishagoride885
sakalrip