Поделитесь своими знаниями, ответьте на вопрос:
1. Введите с клавиатуры в массив десять вещественных значений. Выведите их в одну строку через пробел. Отсортировать по убыванию и вывести полученный массив на экран. 2. Составьте программу упорядочения по убыванию элементов каждого столбца двумерного массива C[1.5, 1..6]. Массив заполнен случайными целыми числами от -20 до 20 решить эти две задачи по PascalABC с алгоритма и программ с использованием методов внутренней сортировки.
a, b, c, d: real;
begin
write('Введите коэффициенты a,b,c ');
readln(a, b, c);
d := sqr(b) - 4 * a * c;
if d = 0 then
writeln('Корень один x = ', (-b / (2 * a))
else if d >0 then
writeln('x1 = ',(-b + sqrt(d)) / (2 * a), ' x2 = ',(-b - sqrt(d)) / (2 * a))
else writeln('Действительных корней нет');
end.
Тест №1
Введите коэффициенты a,b,c 1 -5 6
x1 = 3 x2 = 2
Тест №2
Введите коэффициенты a,b,c 1 2 3
Действительных корней нет
Тест №3
Введите коэффициенты a,b,c 1 0 0
Корень один x = 0