Поделитесь своими знаниями, ответьте на вопрос:
Решить задачи и к каждой задаче построить блок-схему. В программе «:=» обозначает оператор присваивания, знаки «+», «-», «*» и «/» — соответственно операции сложения, вычитания, умножения и деления. Правила выполнения операций и порядок действий соответствуют правилам арифметики. Определите значение переменной b после выполнения алгоритма:а := 7b := 4а := 2*а + 3*bb := a/2*bалгначцел s, tввод sввод tесли s > 6 и t < 7 то вывод "YES" иначе вывод "NO"всеконБыло проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:(7, 3); (2, 7); (6, 10); (5, 3); (5, 4); (–11, 4); (–8, 9); (7, 3); (9, 1Запишите значение переменной s, полученное в результате работы следующей программы.алгнач цел s, k s := 8 нц для k от 3 до 8 s := s + 8 кц вывод s кон
#include <cstdlib>
#include <ctime>
int main()
{
using namespace std;
cout << "Enter size of array: ";
int N;
cin >> N;
int * ARR = new int[N];
srand(time(0));
int i;
for (i = 0; i < N; ++i)
ARR[i] = rand() % 100 + 1;
cout << "Here is an original array:\n";
for (i = 0; i < N; ++i)
cout << ARR[i] << " ";
cout << endl;
int temp = ARR[N - 1];
for (i = N - 1; i > 0; --i)
ARR[i] = ARR[i - 1];
ARR[0] = temp;
cout << "\nHere is a new array:\n";
for (i = 0; i < N; ++i)
cout << ARR[i] << " ";
cout << endl;
return 0;
}