?>
Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность) Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чётных чисел кратных 5. Для записи программы используйте приведенные переменные: var a, n: integer begin n:=0 readln (a) ... writeln(n) end
Ответы
Я так понимаю из задания вы это хотели.
В следующий раз самостоятельно хоть попытайтесь сделать,и приложите ваше решение к вопросу.
#include<iostream>;
using namespace std;
int main()
{
int n;
float height, width,square=0;
cout << "pls enter count rectangle" << endl;
while (true) //Бесконе4ный цикл
{
cin >> n;
if (n <= 10 && n > 0)//как нашли-выходим из цикла
break;
}
cout << "pls enter height" << endl;
cin >> height;
cout << "pls enter width" << endl;
cin >> width;
cout << endl;
for (int i = 0; i < n; i++)
{
square = square + (height * width);
}
cout <<"your answer : "<< square << endl;
system("pause");
return 0;
}