Volkov
?>

Можно программу на языке паскаль ":) Составить программу нахождения суммы всех делителей заданного натурального числа N. (Само число и единица включаются в число делителей.) Формат входных данных Входной файл содержит число N (1≤N≤1000 Формат выходных данных Выведите искомую сумму. Примеры: Вход 3 Выход 4

Информатика

Ответы

Olegovna Volkov

var sum,i,N:integer; t,t1:text;

begin

 assign (t, 'input.txt'); reset(t);

 assign (t1, 'output.txt'); rewrite(t1);

read(t,N);

sum:=0;

for i:=1 to N do

 if N mod i = 0 then sum:= sum+i;

write(t1,sum);

close(t1)

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Можно программу на языке паскаль ":) Составить программу нахождения суммы всех делителей заданного натурального числа N. (Само число и единица включаются в число делителей.) Формат входных данных Входной файл содержит число N (1≤N≤1000 Формат выходных данных Выведите искомую сумму. Примеры: Вход 3 Выход 4
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

apetrov54
Nazart44446
baranova302
Морозов
ivanandrieiev1984268
vnolenev
mado191065
dmtr77
lenskiy
isaev
jgaishun756
leeka152522
ars-trushakova
Imarmy67
kapriz1999