Васенкова204
?>

обджект паскаль1. Массив X-целочисленный задать по вводу, n =16. В массиве X найти сумму нечетных элементов. Заменить первый положительный элемент на эту сумму. Вывод исходного массива и всех результатов c комментариями в F1Book. Формат вывода в столбик.2. Матрицу В(4, 4), задать по вводу. Найти максимальный элемент матрицы. Отрицательные элементы главной диагонали заменить на полученное число. Вывод исходного массива и всех результатов в Label.

Информатика

Ответы

rb-zakaz

//Задача 3

#include <iostream>

#include <stdio.h>

using namespace std;

string SubString(string str, int startIndex, int endIndex)

{

   string output = "";

   for (int i = startIndex; i < endIndex; i++)

       output += str[i];

   return output;

}

string ToString(int num)

{

   string output = "";

   char symbol = 0;

   int tmp = num;

   while(num != 0)

   {

       tmp = num % 10;

       num /= 10;

       symbol = (char)(tmp + 48);

       output = symbol + output;

   }

   return output;

}

int IndexOf(string str, char symbol)

{

   int index = -1;

   for (int i = 0; i < str.length(); i++)

   {

       if (str[i] == symbol)

       {

           index = i;

           break;

       }

   }

   return index;

}

bool Contains(string text, char symbol)

{

   for (int i = 0; i < text.length(); i++)

   {

       if (text[i] == symbol)

           return true;

   }

   return false;

}

bool IsRepeat(string values, string num)

{

   string tmp = "";

   while (IndexOf(values, ' ') != -1)

   {

       values = SubString(values, IndexOf(values, ' ') + 1, values.length() + 1);

       tmp = SubString(values, 0, IndexOf(values, ' '));

       if (tmp == num)

           return true;

   }

   return false;

}

int main()

{

   const int arrSize = 10;

   int arr[arrSize] = { 10, 22, 10, 76, 44, 22, 22, 12, 9, 76};

   string values = "";

   bool couples = false;

   for (int i = 0; i < arrSize; i++)

   {

       string str = ToString(arr[i]);

       for (int j = i + 1; j < arrSize; j++)

       {

           if (arr[i] == arr[j] && !IsRepeat(values, ToString(arr[j])))

           {

               str += " " + ToString(arr[j]);

               values += " " + ToString(arr[j]);

           }

       }

       if (Contains(str, ' '))

       {

           couples = true;

           cout << "Couple: " << str << endl;

       }

   }

   if (!couples)

       cout << "Couple not detected!" << endl;

   return 0;

}

--------------------------------------------------------------------------

//Задача 5

#include <iostream>

using namespace std;

string ToLower(string text)

{

   string output = "";

   for (int i = 0; i < text.length(); i++)

       output += tolower(text[i]);

   return output;

}

int main()

{

   string str1 = "";

   string str2 = "";

   cout << "Enter first string: ";

   getline(cin, str1);

   cout << "Enter second string: ";

   getline(cin, str2);

   if (ToLower(str1) == ToLower(str2))

       cout << endl << "Strings are equal" << endl;

   else

       cout << endl << "Strings are not equal" << endl;

   return 0;

}


Написать программу на c++ выделены

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

обджект паскаль1. Массив X-целочисленный задать по вводу, n =16. В массиве X найти сумму нечетных элементов. Заменить первый положительный элемент на эту сумму. Вывод исходного массива и всех результатов c комментариями в F1Book. Формат вывода в столбик.2. Матрицу В(4, 4), задать по вводу. Найти максимальный элемент матрицы. Отрицательные элементы главной диагонали заменить на полученное число. Вывод исходного массива и всех результатов в Label.
Ваше имя (никнейм)*
Email*
Комментарий*