МихайловнаLarisa1150
?>

найти ошибку в коде для программы код паскаля У вас на столе лежит N монет. Некоторые из них лежат вверх решкой, а некоторые - гербом. Определите минимальное число монет, которые нужно перевернуть, чтобы все монеты были повернуты вверх одной и той же стороной. program coins; var n, i, s, a:longint; begin readln(n); for i:=1 to n do begin readln(a); if a=0 then s:=s+1 end; writeln(s); end.

Информатика

Ответы

ooost-2022
//PascalABC.NET
//Версия 3.3, сборка 1634 (14.02.2018)

begin
  var (cost, t, k) := (Arr(15, 70, 125, 230, 440), Arr(1, 5, 10, 20, 60), new integer[5]);
  var n := ReadInteger('n->');
  for var i := 4 downto 0 do
  begin
    k[i] := n div t[i];n := n mod t[i];
  end; 
  if k[0] * cost[0] >= cost[1] then begin k[0] := 0;inc(k[1]); end;
  if k[0] * cost[0] + k[1] * cost[1] >= cost[2] then 
  begin
    k[0] := 0;k[1] := 0;inc(k[2]); 
  end;
  if k[0] * cost[0] + k[1] * cost[1] + k[2] * cost[2] >= cost[3] then 
  begin
    k[0] := 0;k[1] := 0;k[2] := 0;inc(k[3]);
  end;
  if k[0] * cost[0] + k[1] * cost[1] + k[2] * cost[2] + k[3] * cost[3] >= cost[4] then 
  begin
    k[0] := 0;k[1] := 0;k[2] := 0;k[3] := 0;inc(k[4]); 
  end;
  
  for var i := 0 to 4 do WritelnFormat('{0} билет(ов)- {1} штук(а)', t[i], k[i]);
end.

Пример(1):
n-> 37
1 билет(ов)- 0 штук(а)
5 билет(ов)- 0 штук(а)
10 билет(ов)- 0 штук(а)
20 билет(ов)- 0 штук(а)
60 билет(ов)- 1 штук(а)

Пример(2):
n-> 35
1 билет(ов)- 0 штук(а)
5 билет(ов)- 1 штук(а)
10 билет(ов)- 1 штук(а)
20 билет(ов)- 1 штук(а)
60 билет(ов)- 0 штук(а)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

найти ошибку в коде для программы код паскаля У вас на столе лежит N монет. Некоторые из них лежат вверх решкой, а некоторые - гербом. Определите минимальное число монет, которые нужно перевернуть, чтобы все монеты были повернуты вверх одной и той же стороной. program coins; var n, i, s, a:longint; begin readln(n); for i:=1 to n do begin readln(a); if a=0 then s:=s+1 end; writeln(s); end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

cmenick29
Svetlana395
Maksimova1320
nevzorova
Александровна-Васильевна
Напишите программу в Паскаль:
pereverzev
marinamarinazmeeva2444
КириллЕгорова1906
kris5009646
yurassolo747
marinakmaa86
yuklimochkina3
Anastasiya81
MikhailSvetlana
Светлана308
▲