thedoomsdatdcs36
?>

Паскаль. В заданной строке определить совпадает ли количество круглых открывающихся и круглых закрывающихся скобок

Информатика

Ответы

e90969692976

Пример на продукте - бананы

program v1;

var m,n,sum,t:integer;

st1:string[10];

 begin

   sum:=0; t:=0;

   writeln('Здравствуйте');

   writeln('Банан красного цвета стоит 2500, банан синего цвета стоит 3000, банан черного цвета стоит 3700');

   writeln('Сколько купите бананов '); readln(n);

  writeln('Введите цвет бананов '); readln(st1);

   if (st1='Красного') or (st1='красного') or (st1='Красный') or (st1='красный') then sum:=3000*n;

   if (st1='Синего') or (st1='синего') or (st1='Синий') or (st1='синий') or (st1='Синей') or (st1='синей')  then sum:=2500*n;

   if (st1='Черного') or (st1='черного') or (st1='Чёрного') or (st1='чёрного') or (st1='Черный') or (st1='черный') or (st1='чёрный') or (st1='Чёрный')  then sum:=3700*n;

   writeln('Сумма покупки ', sum);

   writeln('Введите сумму'); readln(m);

   t:=m-sum;

   writeln('Возьмите сдачу ',t);

   writeln('Всего доброго, приходите еще');

 end.


Дорогие программисты по информатике! Напишите программу по этим алгоритмам умоляю

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль. В заданной строке определить совпадает ли количество круглых открывающихся и круглых закрывающихся скобок
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Gor Anatolevich
eidevyatkina
yliana
Владислав-Аветисян217
best00
shumeikoElena362
AlekseiMardanova
pelagia-kola2658
Galinagol559
jeep75
Irina1435
artashhovhan
yugraspets
Бочкарева Горохова1652
Oksana-Kirakosyan1301