?>
НУЖНО Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 км/ч, выведите «YES», иначе выведите «N0». Программа получает на вход число проехавших автомобилей N (1 < N < 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300.Программа должна сначала вывести максимальную скорость, затем YES или NO.
Ответы
# include <iostream>
int main() {
short n;
std::cin >> n;
bool minSpeed = false;
short maxSpeed = INT8_MIN;
short buf;
for (short j = 0; j < n; j++) {
std::cin >> buf;
if (not minSpeed and buf < 30) minSpeed = true;
if (buf > maxSpeed) maxSpeed = buf;
}
std::cout << maxSpeed << "\n" << ((minSpeed) ? "YES" : "NO");
};