annashersheva
?>

написать программу которая генерирует три последовательности случайных чисел и вычисляет среднее арифметическое каждой последовательности (в кумире)

Информатика

Ответы

Yezhov_igor42

=== Python 3.8.3 ===

def fastExp(b, n):

   def even(n):

       if n % 2 == 0:

           return True

       return False

   if n == 0:

       return 1

   if even(n):

       #Можно было написать return fastExp(b, b/2) ** 2, но операцию возведения в степень использовать нам запретили.

       res = fastExp(b, n/2)

       return res*res

   return b*fastExp(b, n-1)

def main():

   base = float(input())

   exp = int(input())

   print(fastExp(base, exp))

if __name__ == "__main__":

   main()

Предложенные тесты проходит. Сам алгоритм быстрого возведения в степень реализован в виде функции fastExp(b, n)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать программу которая генерирует три последовательности случайных чисел и вычисляет среднее арифметическое каждой последовательности (в кумире)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Donat-Evgeniya793
olgalooo
a96849926288
ddavydov1116
omigunova39
ridyana504
arbekova
msangelika1010
bronco-s
Donleksa2016
steff77
volodinnikolay19
Евгеньевич Балиловна1398
Эссе на тему: "мой безопасный интернет"
skalegin68
kv135549