ehrik-ch
?>

Pascal, составить программу с задачей! Компьютер запрашивает радиус круга и сторону квадрата. Надо определить, равные ли у них площади (ответ должен иметь вид: «Площади равные» Если площади не равные, то выводится площадь меньшей фигуры.

Информатика

Ответы

ranocchio6

//s1 - площадь круга, s2 - площадь квадрата

//а - cторона квадрата, r - радиус круга

const pi = 3.14;

var s1,s2,a,r:real;

begin

 write('введите а: ');

 read(a);

 write('введите r: ');

 read(r);

 s1:=pi*sqr(r);

 s2:=sqr(a);

 if s1 = s2 then writeln('площади равные')

 else

   if s1 > s2 then writeln('площадь квадрата: ',s2)

   else

     if s2 > s1 then writeln('площадь круга: ',s1);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal, составить программу с задачей! Компьютер запрашивает радиус круга и сторону квадрата. Надо определить, равные ли у них площади (ответ должен иметь вид: «Площади равные» Если площади не равные, то выводится площадь меньшей фигуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Korinchan390
marinaled8187
Sofinskaya1185
Yevsyukov1697
Мария
laplena1982750
Tatianarogozina1306
arch5050
Marinanagornyak
versalmoda2971
marychev55
partners
Стуканова УЧРЕЖДЕНИЕ1877
що таке діалогові програми​
sryzhova6392
Sinelnikov1650