kotocafe45
?>

та!(PYTHON) Напишите программу которая выполняет циклический сдвиг элементов массива вправо на r элементов.

Информатика

Ответы

helenavalenti2846

К этому:

можно делать сдвиг как вправо, так и влево (на ввод отрицательное число)

Код:

def shift(lst, steps):

   if steps < 0:

       steps = abs(steps)

       for i in range(steps):

           lst.append(lst.pop(0))

   else:

       for i in range(steps):

           lst.insert(0, lst.pop())

   return lst

arr = [1, 2, 3, 4, 5, 6, 7, 8, 9, 10]

shift_num = int(input("Введите сдвиг массива: "))

print(shift(arr, shift_num))

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

та!(PYTHON) Напишите программу которая выполняет циклический сдвиг элементов массива вправо на r элементов.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ilyushin-e
Tatgri
Виктор-Богданов
Как создать сайт для 8 классника
vera2job7
Alenachernika9111
elenarumack
Immortal3331
natalya2321
bristolhouse20151001
Matveevanastya0170
dmitriy
d43irina
travkinadjey31
Sergeevna803
PoleshchukTatyana
▲