?>
Каждая бактерия делится на две в течение одной минуты. В начальный момент имеется одна бактерия. Составьте программу, которая рассчитывает количество бактерий на заданное вами целое значение момента времени (15 минут, 7 минут и т.п.) . Задача решается с циклов на
Ответы
var bak:integer;
begin
readln(bak); //Вбиваем требуемое кол-во минут
/*каждую минуту кол-во бактерий увеличивается вдвое, т.к. вначале мы имеем всего 1 бактерию, то просто умножаем кол-во минут на 2 */
bak:=bak*2;
writeln(bak);
readln;
end.