Поделитесь своими знаниями, ответьте на вопрос:
Вводиться существительное 2ого склонения мужского рода единственном числе. Составьте программу, которая склоняет это слово по падежам
#include <iostream>
using namespace std;
int main()
{
double s, s1, s2, s3;
cout << "1 тенге (KZT) = 0.19 RUB" << "\n";
cout << "1 тенге (KZT) = 0.002743 EUR" << "\n";
cout << "1 тенге (KZT) = 0.002995 USD" << "\n";
cout << "Введите сумму в тенге:", cin >> s, cout << "\n";
s1 = s*0.19;
s2 = s*0.002743;
s3 = s*0.002995;
cout << s << " тенге (KZT) = " << s1 << " RUB, " << s2 << " EUR, " << s3 << " USD" << "\n";
return 0;
}
Пример:
1 тенге (KZT) = 0.19 RUB
1 тенге (KZT) = 0.002743 EUR
1 тенге (KZT) = 0.002995 USD
Введите сумму в тенге:20000
20000 тенге (KZT) = 3800 RUB, 54.86 EUR, 59.9 USD
2 a)
#include <iostream>
using namespace std;
int main()
{
int a = 5;
int b = 4;
int c;
c = a;
a = b;
b = c;
cout << "a = " << a << ", b = " << b << "\n";
return 0;
}
Результат:
a = 4, b = 5
2 b)
#include <iostream>
using namespace std;
int main()
{
int a = 5;
int b = 4;
a = a+b;
b = a-b;
a = a-b;
cout << "a = " << a << ", b = " << b << "\n";
return 0;
}
a = 4, b = 5
3)
#include <iostream>
using namespace std;
int main()
{
int a, b, c;
a = 5;
b = a+3;
c = a+b;
cout << "a = " << a << ", b = " << b << ", c = " << c << "\n";
return 0;
}
Результат:
a = 5, b = 8, c = 13
4)
#include <iostream>
using namespace std;
int main()
{
int p1=10;
int p2=15;
int p3=12;
int k1, k2, k3, s;
cout << "k1 = ", cin >> k1, cout << "\n";
cout << "k2 = ", cin >> k2, cout << "\n";
cout << "k3 = ", cin >> k3, cout << "\n";
s = p1*k1+p2*k2+p3*k3;
cout << "Общая стоимость покупок = " << s << "\n";
return 0;
}
k1 = 2
k2 = 5
k3 = 3
Общая стоимость покупок = 131