ivstigres65
?>

Напишите программу. На числовой прямой отмечены точки А1, А2, А3, ... Аn. Выясните, какому из отрезков [Аi;A(i+1)] принадлежит заданная точка X.​

Информатика

Ответы

lbondareva
Оператор выбора CASE:
...
readln(a);
...
case a of
        0 : writeln ('ноль');
        1 : writeln ('один');
        2 : writeln ('два');
        3 : writeln ('три');
        4 : writeln ('четыре');
        5 : writeln ('пять');
        6 : writeln ('шесть');
        7 : writeln ('семь');
        8 : writeln ('восемь');
        9 : writeln ('девять');
      end;

Условный оператор IF, ELSE
В простом виде:
if (<условие>) 
  then
    <...>
  else 
    <...>

Если внутри блоков с условиями идут несколько операторов, то используется операторная конструкция совместно с begin ... end
if (<условие>)
  then
    begin 
      <... 1>
      <... 2>
      ...
    end
  else 
    begin
      <... 1>
      <... 2>
      ...
    end;

Если а>mах и b<min то с=(а+b)/2 в другом случае с=0 
if(a > max) and (b < min) then
c:= (a+b)/2;
else
c:= 0;

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу. На числовой прямой отмечены точки А1, А2, А3, ... Аn. Выясните, какому из отрезков [Аi;A(i+1)] принадлежит заданная точка X.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tarasova
Сергеевич1396
lelikrom2202
sawa-msk
alexey
ecogoi
armusaeff
Vadim443
Lilykl
Viktoriya405
Ter-Pogosov_Vasilevna
manuchar-formen2
zybin41iz81
Назаров588
valya-7777