iraira761
?>

Задание 6. Составьте программу, которая выводит на экран десять строк таблицы умножения на 2.1 x2 = 22 x2 = 410 х 2 = 20​

Информатика

Ответы

MNA888

Объяснение:

#include <iostream>

using namespace std;

int main()

{

   int N, counter = 1, max_counter=1,post;

   cin >> N;//всего матчей

   cin >> post;// ввод первого числа последовательности  

   for (int i = 0; i < N-1; i++) {

       int a;

       cin >> a;// ввод остальных N-1 чисел последовательности

       if (a == post && a == 1) {

           counter++;

           if (counter > max_counter)

               max_counter = counter;

       }

       else

       {  

           counter = 1;

       }

       post = a;

   }

       cout << max_counter;

   return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задание 6. Составьте программу, которая выводит на экран десять строк таблицы умножения на 2.1 x2 = 22 x2 = 410 х 2 = 20​
Ваше имя (никнейм)*
Email*
Комментарий*