Galkin683
?>

(PASCAL)Напишите программу для решения следующей задачи. Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите самую низкую температуру за время наблюдения. Если температура опускалась ниже –15 градусов, выведите YES, иначе выведите NO. Программа получает на вход количество дней, в течение которых проводилось измерение температуры N (1 ≤ N ≤ 31), затем для каждого дня вводится температура. Пример работы программы:Входные данные4–512–28Выходные данные–5NO

Информатика

Ответы

ngz55

var x:integer;

n: array[1..31] of integer;

begin

 for var i:=1 to 31 do

 begin

   write('Введите температуру ',i,' дня: '); readln(n[i]);

   if n[i]<x then x:=n[i];

 end;

 writeln; writeln('Минимальная тепература: ',x);

 if x<-15 then writeln('YES') else writeln('NO');

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

(PASCAL)Напишите программу для решения следующей задачи. Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите самую низкую температуру за время наблюдения. Если температура опускалась ниже –15 градусов, выведите YES, иначе выведите NO. Программа получает на вход количество дней, в течение которых проводилось измерение температуры N (1 ≤ N ≤ 31), затем для каждого дня вводится температура. Пример работы программы:Входные данные4–512–28Выходные данные–5NO
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

stertumasova29
Guskov
N-odes-art-school410
ok-49566
Ka2ffka141
slavutich-plus2
kotikdmytriy11
Васильевичь Виктория457
ivanova229
Pavlovna897
eliteclassic308
zigrin
Pirogovskii695
denblacky
info-mosbalkon