kiravalter1998697
?>

Прямоугольный остров разделён на квадраты так, что его размеры — N х М квадратов. В каждом квадрате зарыто некоторое число золотых монет, эти данные хранятся в матрице (двумерном массиве) Z, где Z[i, j] — число монет в квадрате с координатами (i, j Пират хочет пройти из юго-западного угла острова в северо-восточный, причём он может двигаться только на север или на восток. Как пирату собрать наибольшее количество монет? Напишите программу, которая находит оптимальный путь пирата и число монет, которое ему удастся собрать. На любом языке программирования:)

Информатика

Ответы

tanya14757702
#include<iostream>
#include<cstdlib>
#include<locale>
#include<ctime>
using namespace std;
int main()
{
  setlocale(LC_ALL, "Russian");

  srand(time(NULL));

  int min_value, max_value;
  int mas[10];

  // инициализируем массив случайными числами
  for(int i=0; i<10; i++) mas[i] = rand()%100;

  //находим минимальное значение
  min_value = mas[0];
  for(int i=0; i<10; i++)
    if(min_value > mas[i]) min_value = mas[i];

  cout << "Минимально значение: " << min_value << '\n';

  //находим максимальное значение
  max_value = mas[0];
  for(int i=0; i<10; i++)
    if(max_value < mas[i]) max_value = mas[i];

  cout << "Максимальное значение: " << max_value << '\n';

  //выводим среднее значение максимального и минимального значение
  cout << "Среднее значение: " << (double) (min_value+max_value)/2 << '\n';
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Прямоугольный остров разделён на квадраты так, что его размеры — N х М квадратов. В каждом квадрате зарыто некоторое число золотых монет, эти данные хранятся в матрице (двумерном массиве) Z, где Z[i, j] — число монет в квадрате с координатами (i, j Пират хочет пройти из юго-западного угла острова в северо-восточный, причём он может двигаться только на север или на восток. Как пирату собрать наибольшее количество монет? Напишите программу, которая находит оптимальный путь пирата и число монет, которое ему удастся собрать. На любом языке программирования:)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

misstimarina2016
Nikolaevich824
stark11
miheev-oleg578
djikia88
adhotel
Дубровская571
tarkhanovilya
Ryadovboxing23
Dubovitskayae
k-alexey9
qadjiyevaaynura
skyey
Konstantin_Vadimirovich
ngoncharov573